WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#11602 closed defect (bug) (worksforme)

Database error during upgrade process

Reported by: mrmist Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Database Keywords:
Focuses: Cc:

Description

Upgrading (via svn) to 3.0 from (some revision around 2.8) gave me a database error - duplicate primary key. Unfortauntely I lost the error message so this is the best bug report I can do for it. Think it was something regarding the meta or options table.

Change History (3)

comment:1 follow-up: Denis-de-Bernardy4 years ago

options table, in all likelihood.

comment:2 in reply to: ↑ 1 nacin4 years ago

Replying to Denis-de-Bernardy:

options table, in all likelihood.

#11266 - related.

I just went from 2.8.1 to trunk r12551. I also tried various 2.8.x tags to both 2.9 and trunk. Could not reproduce. Hmm.

comment:3 Denis-de-Bernardy4 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Yeah, it should only occur with some revisions of trunk. The issue was quickly fixed. Closing as worksforme, since it would only ever affect someone who uses trunk and it's reasonably safe to assume they'd know how to fix it (if they even need to).

Note: See TracTickets for help on using tickets.