Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#11657 closed defect (bug) (duplicate)

Curly quote - when after a number, the quote symbol is wrong

Reported by: AsiaR Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Formatting Keywords: curly quotes, wptexturize
Focuses: Cc:


With wptexturize, when text in quotation marks ends with a number, the close quotation mark HTML character code is wrong. E.g. a post about the U.S.-China "G2" will use the correct opening quote (#8220) before G2 but an incorrect closing quote (#8243). The closing quotation should be #8221. Not sure what the origin of this problem is....

Change History (3)

comment:1 @AsiaR6 years ago

Err, didn't mean for those HTML character codes to come up as tickets! Those are supposed to represent HTML for different forms of quotations.

comment:2 @filosofo6 years ago

Duplicate of #8775

comment:3 @filosofo6 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.