WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11675 closed defect (bug) (duplicate)

Adjacent Short Codes Don't Work

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: major Version: 2.8
Component: Shortcodes Keywords:
Focuses: Cc:

Description

Any time two short codes are placed next to each other, the second short code appears as plain text in the content. This can be reproduced with something as simple as [gallery][gallery] or with a more complex pattern such as two captioned images with no whitespace.

Change History (3)

comment:1 @nacin6 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.9.1 to 3.0

Not a regression, so moving to 3.0. Needs a patch and probably some unit tests.

The shortcode regex relies on surrounding characters, hence the issue. See also #10326, when it was improved to not strip those characters.

comment:2 @TobiasBg6 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #10082, also related: #10490 and #10326

comment:3 @nacin5 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.