WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#11677 closed defect (bug) (duplicate)

Double-click comment shortcut wipes out any already open comment edit box

Reported by: richards1052 Owned by:
Milestone: Priority: high
Severity: major Version: 2.9
Component: Comments Keywords: comment, shortcut, edit, double-click
Focuses: Cc:

Description

Currently, WP's comment editing function has a built in "shortcut" which allows the user to double click on any word in a comment on the comment edit page, which opens the comment edit box:

"A final secret shortcut is double-click. Just click twice on a comment in the Comments view to open up the editor."

The problem with this shortcut is that when a user has already opened the comment Reply box and has highlighted a word or phrase fr. a published comment in order to copy & paste the word/phrase into the open comment edit box, & accidentally double clicks the highlighted word/phrase, this causes the user to completely lose the comment he was editing/writing. I've wiped out countless comments in this fashion & it's very frustrating.

The way this shortcut SHOULD work imo is that it should be coded to check whether a comment edit box is already open & if one is it should not wipe out the exising open one. Or alternatively, there should be a provision for users to configure their comment feature to disable the double click shortcut.

Frankly, I can't believe this shortcut is used by many folks compared to the number who've faced the huge inconveniences caused by it.

Change History (5)

comment:1 @nacin5 years ago

  • Keywords reporter-feedback added; comment shortcut edit double-click removed
  • Type changed from enhancement to defect (bug)

This has previously been reported. I recall checking every major browser (IE6 on up) and could not replicate.

What browser and OS? If you have any other steps to reproduce, I'm sure it'll help.

We might just need to code in a sanity check to make sure we don't mess with an inline edit in progress.

comment:2 @nacin5 years ago

The first was #11328.

comment:3 @richards10525 years ago

  • Keywords comment shortcut edit double-click added; reporter-feedback removed
  • Type changed from defect (bug) to enhancement

Firefox & Vista.

And the really weird thing about this is that Firefox is usually very good about retaining a pg. in its cache so that if something like this happens you can use the Back button to retrieve the page version you lost. But when you do that it doesn't work.

I have someone I work with on WP technical issues & he's been able to replicate it as well.

comment:4 @richards10525 years ago

I've just tried replicating this on IE AND Chrome & it does it in both browsers. I'm not sure why you weren't able to replicate it in IE. If you want me to walk you through it step by step I can do that as well if it would help.

comment:5 @nacin5 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from enhancement to defect (bug)
Note: See TracTickets for help on using tickets.