WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#11681 closed defect (bug) (fixed)

Erratic Behavior When wp-includes/pomo Missing

Reported by: miqrogroove Owned by: westi
Milestone: 3.0 Priority: normal
Severity: normal Version: 2.8
Component: I18N Keywords: commit
Focuses: Cc:

Description

WordPress throws

Fatal error: Class 'NOOP_Translations' not found in /wp-includes/l10n.php on line 437

I believe this is caused by erroneous use of "include_once" in wp-settings.php, where "require_once" was intended.

See it in the wild at http://wordpress.org/support/topic/344708

Change History (3)

comment:1 westi4 years ago

  • Component changed from General to i18n
  • Milestone changed from 2.9.1 to 3.0
  • Owner set to westi
  • Severity changed from critical to normal
  • Status changed from new to accepted

I don't see how switching to require_once instead of include_once would fix this.

The file which includes the NOOP_Translations class wp-includes/pomo/translations.php has always existed and the way this is pulled in hasn't changed between 2.8 and 2.9.

The content of the file has though - http://bit.ly/66oWKa

Moving to 3.0 - I can see the argument for using require over include here as the content of the files is needed.

comment:2 miqrogroove4 years ago

  • Keywords commit added

westi, do you need a patch?

comment:3 nacin4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.