Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11693 closed defect (bug) (invalid)

Google Redirection Error

Reported by: miqrogroove Owned by: markjaquith
Milestone: Priority: normal
Severity: major Version: 2.8.4
Component: Canonical Keywords:
Focuses: Cc:


Investigating an invalid namespace identified by Webmaster Tools. At first glance, it appears the %2F bug is back. See #8965. However, I was able to reproduce it with qTranslate disabled this time.

I'll work to narrow this down and come up with minimal steps to reproduce.

Change History (6)

comment:1 @miqrogroove6 years ago

hmmmm The symptom disappeared after a mass deactivation, so I might have a different plugin screwing with the superglobals...

comment:2 @miqrogroove6 years ago

Core Control is my new suspect...

comment:3 @miqrogroove6 years ago

Steps to reproduce:

  1. Install and activate Core Control
  1. Hit root path /&a=/

comment:4 @nacin6 years ago

  • Milestone 2.9.1 deleted

Okay, since this is a plugin, then we can close this, correct? I've let dd32 know.

comment:5 @miqrogroove6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Steps to reproduce:

  1. Install and activate Core Control
  1. Enable any Core Control Module
  1. Hit root path /&a=/

comment:6 @dd326 years ago

FYI, It came down to this line:

$_SERVER['REQUEST_URI'] = remove_query_arg(array('module_action'));
Note: See TracTickets for help on using tickets.