WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11708 closed defect (bug) (worksforme)

RSS Feeds Not Working After Upgrading To WordPress 2.9

Reported by: mtroche13 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Feeds Keywords: reporter-feedback
Focuses: Cc:

Description

Hello.

I run a high-traffic site so this is problem is of high-priority to me.

After upgrading to WordPress version 2.9 my feeds have stopped working. Going to any feed link redirects to my site's homepage, including my feedburner feed.

Site: http://blackberryrocks.com
Feed used: http://blackberryrocks.com/?feed=rss2
Feedburner: http://feeds.feedburner.com/BlackBerryRocks

I'm not getting any errors and can't check for any since all the links do is redirect to homepage. I use the Feedburner Feedsmith plugin but I tried disabling it to view original feed (feed used) and still nothing but redirects.

Change History (14)

comment:1 dd324 years ago

  • Keywords reporter-feedback added; feeds rss feed removed
  • Milestone changed from Unassigned to Future Release
  • Priority changed from highest omg bbq to normal
  • Severity changed from blocker to normal

Have you disabled ALL plugins, and changing the permalink structure to default and back to whatever you currently have it set to?

Have you seeked help in the Support Forums?

Setting to normal priorities as this strongly sounds like a Plugin issue, as there have not been any other reports of feeds breaking.

comment:2 mtroche134 years ago

I've tried everything you said and could not find adequate help in the Support Forums right now, although I did not personally post something, I searched for a similar problem.

It doesn't seem to be a plugin or permalink issue as far as I can tell.

comment:3 scribu4 years ago

Try upgrading to 2.9.1 RC1 as it has some fixes related to feeds. You can use the WP Beta Tester plugin for this.

comment:4 mtroche134 years ago

Ok I updated to the latest "point release nightly" but the feeds are still just going to the homepage and not working.

comment:5 scribu4 years ago

Revert to the default theme and see if you're still redirected.

comment:6 mtroche134 years ago

I can't do that right now. Peak traffic time.

I will do that when traffic is minimal (most likely overnight) and report back.

comment:7 scribu4 years ago

Or you could use a plugin like Theme Test Drive.

comment:8 mtroche134 years ago

Ok I did it using Theme Switcher but it didn't work.

The "Entries (RSS)" link at the bottom links http://blackberryrocks.com/feed/ but all it does is redirect to homepage still.

Was the way feeds are handled changed in any way?

comment:9 scribu4 years ago

There weren't any changes related to the feed URL that I know of.

comment:10 scribu4 years ago

Try adding this line in your theme's functions.php:

remove_action('template_redirect', 'redirect_canonical');

comment:11 miqrogroove4 years ago

Hi mtroche13,

Sorry you didn't get any good help in the forums.

Your server is transmitting an Apache ErrorDocument at the /feed/ path. As such, I would say all of the above discussion is irrelevant. If you still suspect the problem was actually caused by the WordPress upgrade, then there could be some sort of bug that has corrupted your .htaccess file. If you could attach a copy of that file to this ticket, that would help identify where the problem came from.

comment:12 azaozz4 years ago

No other reports of this and your comments feed seems to work properly so it's most likely plugin related. Also check your .htaccess for any rules that redirect feeds or attach a copy here as miqrogroove suggested (remove any sensitive parts first).

comment:13 miqrogroove4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Closing on resolution with lack of feedback.

comment:14 sirzooro4 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.