WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#11709 closed defect (bug) (invalid)

Unable to either add or edit a post or page

Reported by: jerice50 Owned by:
Milestone: Priority: high
Severity: major Version: 2.9
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

I am unable to either add or edit a post or a page.
This issue concerns only one (so far) of my 8 current wp sites.

I have changed and then uninstalled and reinstalled the theme
removed all plugins
reinstalled 2.9
and searched these pages for a hint as to what might be the problem.

I have no interest in losing about 10,000 hours worth of work on my other sites, and I refuse to reformat my hard drive (which was seriously suggested to me)

I searched the forums first, and apparently I am not the only one experiencing this horror. One complainer thought it may be an issue with Earthlink, but I do not use Earthlink (and besides, my other sites work ok)

The issue is becoming critical, as I have been able to post no updates, and the content grows more stale by the minute.

Change History (8)

comment:1 sirzooro4 years ago

What happens when you try to add or edit post or page? Do you get any error message?

comment:2 scribu4 years ago

To be able to see error messages, add this line to wp-config.php:

define('WP_DEBUG', true);

comment:3 scribu4 years ago

  • Component changed from General to Administration
  • Keywords reporter-feedback added; edit post removed

comment:4 Denis-de-Bernardy4 years ago

  • Cc Denis-de-Bernardy added
  • Milestone changed from Unassigned to 2.9.2
  • Priority changed from high to normal
  • Severity changed from blocker to major

comment:5 fob4 years ago

  • Cc fob added
  • Priority changed from normal to high

An equal problem here:

One of my projects has been upgraded from 2.9 to 2.9.1. There have been some issues after manual upgrade (stopped with blank page, left homepage blank and some things did not work within the admin) so the system was upgraded again, this time automatically. After all everything seemed to work fine with some exceptions:

Some elder articles as well as newer ones with some revisions can suddenly not be edited anymore. Instead of saving new content there is a redirect with login request - again and again and again... Deactivating all plugins does not help.

Writing the same article again (including all pictures, custom fields and other content) seems to work fine for a while. I thought it could have something to do with revision controls but: Sometimes you can edit 10 times, sometimes 3 edits already seem to be too much for this article. Changing the owner of a post (using quick edit function) is freezing an article, too! (Can never be changed again. Neither from yourself nor from the new owner of this post nor from any other person with administration rights).

Debug mode does not help as I can not find any error information.
--- Debian Root Server, mySQL5, PHP5, Firefox, IE, WP 2.9.1 DE ---

comment:6 WraithKenny4 years ago

just a shot in the dark, but worth a try, is to increase the memory allocation to php.

  1. Increase the memory limit setting in php.ini e.g. (memory_limit = 64M ;). Many hosts may not allow this.
  1. Increase the memory limit via .htaccess e.g. (php_value memory_limit 64M). Many hosts may not allow this.
  1. Increase the memory limit via wp-config.php e.g. (define('WP_MEMORY_LIMIT', '64MB');)

comment:7 mrmist4 years ago

There seems to be little movement on this probably because it's not reproducable. Perhaps if the OP is willing they could dump their database through phpmyadmin so that it can be checked out. That could possibly determine if it's a glitch introduced within the database, or an environmental issue. I'd be willing to check that out if the database dump could be provided.

comment:8 nacin4 years ago

  • Milestone 2.9.3 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Re-open with steps to reproduce or try the support forums.

Note: See TracTickets for help on using tickets.