WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11714 closed defect (bug) (invalid)

Tags disappearing after Saving / Publishing

Reported by: Astriker Owned by: azaozz
Milestone: Priority: high
Severity: normal Version:
Component: JavaScript Keywords: reporter-feedback
Focuses: Cc:

Description

When creating a new post, click Tags, select "Choose from the most used tags in Post Tags". I select several tags, and click Publish. Once it publishes the post, the tags are no longer present in the Tags Field, however they appear in the post. With the post still open, select the same "Choose from the most used tags in Post Tags", select any tag, and they reappear with the "x" to delete them from the post.

Attachments (5)

Screen shot 2010-01-04 at 6.38.14 PM.2.png (62.4 KB) - added by Astriker 4 years ago.
Successfully added the tags from the "Choose from the most used tags in Post Tags"
Screen shot 2010-01-04 at 6.38.55 PM.png (80.0 KB) - added by Astriker 4 years ago.
Click Save Draft (or Publish) the tags go away from the post
Screen shot 2010-01-04 at 6.41.28 PM.png (108.6 KB) - added by Astriker 4 years ago.
Select the "Choose from the most used tags in Post Tags" and select any tag
Screen shot 2010-01-04 at 6.41.33 PM.png (123.8 KB) - added by Astriker 4 years ago.
The previously selected Tags reappear, and are on the post in the "edit" but not until you select one
1.PNG (70.8 KB) - added by Astriker 4 years ago.
Enter Text box shows default text while typing

Download all attachments as: .zip

Change History (20)

Astriker4 years ago

Successfully added the tags from the "Choose from the most used tags in Post Tags"

Astriker4 years ago

Click Save Draft (or Publish) the tags go away from the post

Astriker4 years ago

Select the "Choose from the most used tags in Post Tags" and select any tag

Astriker4 years ago

The previously selected Tags reappear, and are on the post in the "edit" but not until you select one

comment:1 scribu4 years ago

  • Keywords reporter-feedback added

What browser (including version) are you using?

comment:2 scribu4 years ago

  • Component changed from General to JavaScript
  • Owner set to azaozz

comment:3 scribu4 years ago

Can't reproduce using 3.0-alpha using Firefox 3.5.

comment:4 Astriker4 years ago

Safari - Version 4.0.4 (6531.21.10) and 3.5.6 in Firefox

comment:5 sirzooro4 years ago

This sounds like a known issue with DB Cache plugin - if you use it, please replace it with DB Cache Reloaded.

comment:6 sirzooro4 years ago

Never mind - DB Cache removed tags, but in your case tags are present but not displayed.

comment:7 Denis-de-Bernardy4 years ago

any chances you're using a persistent object cache? (the file would be at wp-content/object-cache.php)

comment:8 Denis-de-Bernardy4 years ago

  • Milestone changed from Unassigned to 3.0

it could also be that you've some old js cached in your browser

Astriker4 years ago

Enter Text box shows default text while typing

comment:9 follow-up: Astriker4 years ago

I don't have a cache plug in, I did have a super cache plugin but have deleted it for sometime. Under wp-content->cache->meta is the only folder in a "cache folder". I have cleared the cache and history on both Safari and Firefox.

I attached a new photo, of when I type how it shows the other text underneath. I installed Firebug for another issue, and this page is loading with 2 errors -

make_slugedit_clickable is not defined
http://astriker.com/blog/wp-content/plugins/more-fields/post.js?ver=20091208
Line 223

makeSlugeditClickable is not defined
http://astriker.com/blog/wp-admin/load-scripts.php?c=1&load=hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,suggest,wp-lists,jquery-ui-core,jquery-ui-sortable,postbox,thickbox,media-upload,word-count&ver=95753908d748f48416e644c75f3eef6f
Line 41

comment:10 Denis-de-Bernardy4 years ago

can you re-upload your WP files in case it makes a difference? it sounds like an FTP problem occurred during an upgrade.

comment:11 Astriker4 years ago

Can that be done via the Beta / Upgrade link within the application? Or must I download it and FTP it up?

comment:12 Astriker4 years ago

I deactivated the plugin "more-fields" and unfortunately the website is not functioning when I post now www.astriker.com/blog/ . I think I may have to reinstall all of the WP-Content files.

comment:13 in reply to: ↑ 9 azaozz4 years ago

  • Milestone 3.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 3.0 deleted

Replying to Astriker:

makeSlugeditClickable is not defined
http://astriker.com/blog/wp-admin/load-scripts.php?c=1&load=hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,suggest,wp-lists,jquery-ui-core,jquery-ui-sortable,postbox,thickbox,media-upload,word-count&ver=95753908d748f48416e644c75f3eef6f
Line 41

It seems the "more-fields" plugin is removing (unregistering) the default post.js file and replacing it with an old version. Either update the plugin or contact the author if no update is available.

You can also try copying the new post.js file from wp-admin/js to the plugin's directory overwriting the old one but that may break this plugin.

comment:14 Astriker4 years ago

I did find it was breaking this and causing the other issue, with the thumbnails, Thank you! Great response and support!

comment:15 Astriker4 years ago

The fix, if anyone else should ever use it, - http://labs.dagensskiva.com/forum/topic.php?id=234

Note: See TracTickets for help on using tickets.