WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11716 closed defect (bug) (duplicate)

A Problem With Feed URL

Reported by: clickkt Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Rewrite Rules Keywords:
Focuses: Cc:

Description

I' having a problem with feed URL:
Fatal error: Maximum execution time of 60 seconds exceeded in /home/clickktc/public_html/wp-includes/rewrite.php on line 851

I contacted to my host to increase Maximum execution time to over 60 seconds but couldn't fix this error.
Please help me.

Attachments (1)

rewrite.php (57.6 KB) - added by clickkt 6 years ago.
Rewrite,PHP

Download all attachments as: .zip

Change History (10)

@clickkt6 years ago

Rewrite,PHP

comment:1 @scribu6 years ago

  • Component changed from General to Rewrite Rules
  • Keywords reporter-feedback added; problem wordpress 2.9 removed
  • Milestone changed from WordPress.org site to Unassigned
  • Owner set to ryan
  • Version changed from 2.9.1 to 2.9

What permalink structure do you use?

comment:2 @clickkt6 years ago

I'm using /%postname%/ permalink structure! Please help!

comment:3 @scribu6 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Your permalink structure forces WP to generate verbose rules. If you have a lot of posts or pages, you will run into all sorts of problems.

Consider using a more efficient permalink structure. See this article.

Marking as duplicate of #8958.

comment:4 @clickkt6 years ago

No way can help me?

comment:5 @scribu6 years ago

  • Keywords reporter-feedback removed

Until the mentioned ticket gets fixed, there isn't much else you can try.

comment:6 @dd326 years ago

The best thing you can try at this stage, would be to use something such as /posts/%postname%/. Having a prefix to it greatly decreases the complexity of the rules. post-%postname% may also have the same effect.

comment:7 @clickkt6 years ago

I can't do that because its will influence for SEO

comment:8 @dd326 years ago

I can't do that because its will influence for SEO

So will the current issue of random PHP timeouts preventing access to content, I'd be surprised if this was limited to feeds only.

But if that solution is not a solution to you, You'll have the unfortunate answer of reducing your post count or waiting for a different query parser in WordPress. (Reducing the post count will reduce the number of potential posts it tries to match, making it a bit faster)

comment:9 @scribu6 years ago

Or, you could try setting the feed URL in Feedburner to this:

http://yoursite.com/?feed=rss2

Note: See TracTickets for help on using tickets.