WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#11724 closed defect (bug) (duplicate)

Tags with spaces and utf-8 chars do not work on the default theme

Reported by: hakre Owned by: hakre
Milestone: Priority: normal
Severity: normal Version:
Component: Charset Keywords:
Focuses: Cc:

Description

In #11669 I did a test with the tag test -נ- end which did work. While today surfing the frontend (theme) which is the default one on my testbed, It came to my attention that when clicking the tag's link below the post, I get directed to a false location:


As you can see, the spaces are removed. They either should not be removed (which I doubt will get fixed) or the slugs creation of the tags should take that behaviour into account and strip spaces as well.

I assume that this is clean_url() related.

It might be the case that the tags lookup does not work with UTF-8 as well. This should be checked before the space problem. Maybe the one is a symptom of the other.

Change History (8)

comment:1 hakre4 years ago

Maybe Related: #9591

comment:2 scribu4 years ago

  • Component changed from General to WordPress.org
  • Milestone changed from 3.0 to WordPress.org site
  • Owner set to ryan

Default theme was removed.

comment:3 nacin4 years ago

  • Component changed from WordPress.org to Charset
  • Milestone changed from WordPress.org site to Future Release
  • Owner changed from ryan to hakre

I may be mistaken, but this sounds like an issue with slug handling, not the default theme. It's just reproducible there.

comment:4 hakre4 years ago

Related: #13413

comment:5 hakre4 years ago

Related: #14292

comment:6 hakre4 years ago

I was able to write a patch that fixes a related issue: #13413

It fixes this issue here as well.

comment:7 SergeyBiryukov3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Since there is already a patch for it in #13413, I guess this ticket can be closed as a duplicate. If not, reopen.

comment:8 nacin3 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.