WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 2 years ago

#11733 closed enhancement (duplicate)

do a sanity check when conduction upgrades

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

In the FTP transports, and possibly in the SSH transport, we should look into conducting a quick sanity check after WP transfers a file during upgrades. This would be in the event that a network problem occurs during the upload.

Depending on how robust we want it, it could be as simplistic as checking the file's size, or as complex as using md5_file().

Change History (2)

comment:1 @nacin6 years ago

  • Milestone changed from 3.0 to Future Release

comment:2 @dd322 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18201 (Verify updates with md5's)
Also related to #25237 (WP_Filesystem fails to verify files were written to disk correctly)

Note: See TracTickets for help on using tickets.