WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 months ago

#11735 closed enhancement (wontfix)

unwrap text in theme and plugin editors

Reported by: miken32 Owned by:
Milestone: Priority: lowest
Severity: minor Version: 3.0
Component: Themes Keywords:
Focuses: Cc:

Description

Anyone who actually has to do any editing in these boxes must know what a pain word wrap is, especially when dealing with PHP that's tab-indented a few times.

A little CSS is all that's needed for the appropriate textarea elements:
white-space: nowrap; overflow: auto;

Change History (3)

comment:1 edward mindreantre4 years ago

  • Cc edward mindreantre added
  • Component changed from Administration to Themes
  • Milestone changed from Unassigned to Future Release
  • Priority changed from normal to lowest

Actually that doesn't work.

white-space: nowrap takes care of actual HTML elements. The text inside a textarea is not html therefore isn't affected by nowrap.

In fact, CSS has no attributes for textareas when it comes to wrapping.

There is a "solution": wrap="off" as a textarea setting.
The problem is that it's non-standard although understood by both Firefox and IE.

So now you've got a choice:

  1. In theme-editor.php, line 198, add wrap="off" and then break the HTML validation
  2. Make the textarea a tinymce edit box
  3. Live with the word wrapping and use notepad/gedit to copy/paste to.

I vote for #3.

#2 is also acceptable, since I doubt people are gonna commit suicide waiting for tinymce to load.

comment:2 WraithKenny3 years ago

There used to be a cool editor that had code coloring, but it got killed because it wasn't working in Opera or something... It'd be nice to bring back something similar.

Bespin/Skywriter/ACE is looking pretty cool... but it's early and FF/Webkit focus so far.

TinyMCE might work... but only without wpautop! (laughing just thinking about it.)

comment:3 ocean903 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I agree with edward mindreantre here.

Note: See TracTickets for help on using tickets.