Make WordPress Core

Opened 19 years ago

Closed 19 years ago

#1178 closed defect (bug) (fixed)

user creation and edition bug

Reported by: denis-de-bernardy's profile Denis de Bernardy Owned by: ryan's profile ryan
Milestone: Priority: normal
Severity: critical Version: 1.5.1
Component: Administration Keywords:
Focuses: Cc:

Description

steps to reproduce:

  • create a new user normally, as admin
  • save the user
  • click edit the user, don't change anything
  • save the user

produces the following error:

ERROR: you typed your new password only once. Go back to type it twice.

Attachments (1)

fix_1178.patch (604 bytes) - added by Denis de Bernardy 19 years ago.

Download all attachments as: .zip

Change History (8)

#1 @Denis de Bernardy
19 years ago

  • Patch set to No

#2 @ryan
19 years ago

Same as 1079?

http://mosquito.wordpress.org/view.php?id=1079

Are you using the latest nightlies?

#3 @Denis de Bernardy
19 years ago

yep on both counts: same bug. using nightlies.

#4 @ryan
19 years ago

Okay, I'm seeing it now. Will investigate.

#5 @idanso
19 years ago

Attached what appears to be a fix..

#6 @Sebbi
19 years ago

Just replace the "==" in line 43 in file wp-admin/user-edit.php with "!=" and the problem is solved ...

duplicate of 1101 and 1079 (both are marked as resolved while they aren't, at least not in the version I checked out just seconds ago)

#7 @ryan
19 years ago

  • fixed_in_version set to 1.5.1
  • Owner changed from anonymous to rboren
  • Resolution changed from 10 to 20
  • Status changed from new to closed

user-edit.php was missed when profile.php was fixed. Now both places should be fixed.

http://trac.wordpress.org/changeset/2489

Note: See TracTickets for help on using tickets.