WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 12 years ago

#1181 closed defect (bug) (worksforme)

comment posting leads to blank page

Reported by: Carla Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.0.3
Component: General Keywords:
Focuses: Cc:

Description

When a comment is submitted, the user is then directed to a blank page--the address url is wp-commments-post.php.

Change History (35)

#1 @Carla
13 years ago

  • Patch set to No

#2 @michel v
13 years ago

Please, please, PLEASE provide more information about your setup. I've seen this happen on another host, so we need all the information we can to find just what the bug can be.

#3 @anonymousbugger
13 years ago

Here's my phpinfo printout: <a href="http://www.hauntedpalace.net/phpinfo.php">http://www.hauntedpalace.net/phpinfo.php</a>. Dreamhost is my host. If you need any more info (my plugins, etc.), just ask, and I'll do my best to help you ferret out this problem. :)

#4 @Carla
13 years ago

That last note was from me--sorry about that.

#5 @anonymousbugger
13 years ago

I am also having this issue. It occured on WP 1.5, Apache 2.0.53, PHP 4.3.11, and MySQL 4.1.10a.

I changed my setup after not being able to get around this bug. I changed to WP 1.5.1-alpha and PHP 5.0.4, got the same results as with PHP 4 and stable WP 1.5.

It happens for me even when I have no plugins active and using the default WP 1.5 theme, so it's not an issue with my templates comment page.

There's no relavent information in my apache error logs. I have a few virtual sites setup for my own use in httpd.conf. I'm using mod_proxy with apache. Using mod_proxy to foward http requests for a certain domain to a totally seperate www server on my LAN.

If there's anymore info that's required please let me know. You can see my phpinfo here: http://www.longren.org/phpinfo.php

Note: I tried to register an account on mosquito, never got my confirmation e-mail, at least I haven't as of yet.

tyler

#6 @tlongren
13 years ago

After looking more into this @ home, I found the offending code in the wp_new_comment function in wp-includes/functions-post.php.

Lines 512 to 518. It's the spam checking code. I commented it out and the page is no longer blank after submitting a comment.

Can anyone confirm??

#7 @Denis de Bernardy
13 years ago

I've a user who is getting a blank page as well. I'm redirecting him to here, in case this helps.

He mentions the following:

Warning: call_user_func_array(): First argumented is expected to be a valid callback, 'Markdown' was given in /usr/local/apache/htdocs/wp- includes/functions.php on line 893

I'm completely unable to reproduce so I presume this is some kind of spam code problem rather than a Markdown problem.

#8 @Denis de Bernardy
13 years ago

Update -- I set up tlongren's method with no success.

#9 @Denis de Bernardy
13 years ago

Could it be that the WP spam fighting procedures are causing the problem? If your session times out for any reason, you would be considered a 'new session' that starts with a 'post new comment' page rather than 'display a post' page for you to comment immediately after. Posting a comment directly would be a typical bot behavior...

The full details of another user who encountered a problem: Mac with MacOS 10.3.9, FireFox 1.0.3, cable modem with Comcast, default preferences, no connection problems while he was commenting. The same user can leave comments on his WP install, so it may be a timeout problem or something like that. Any thoughts?

#10 @Denis de Bernardy
13 years ago

http://wordpress.org/support/topic/33847

the following blog apparently delivers a blank page on comments systematically:

http://ocel.co.uk/randomo/

I tested with WinXP, IE and FF, default settings on both, Cable modem connection with no performance issues at time of posting. I get a blank page...

edited on: 05-15-05 23:24

edited on: 05-15-05 23:24

#11 @anonymousbugger
13 years ago

I'm having this problem as well.

I changed nothing and it suddenly happened, upgrading to 1.5.1 did not fix it.

WP 1.5.1 PHP 4.3.10 MYSQL 4.0.24-standard Apache 1.3.33 (Unix)

I use Win XP, Firefox, ntl cable broadband, does not work in IE either.

I've tested this on a number of friends different PCs and it doesn't work for them either.

My wp install is at http://randomo.ocel.co.uk

edited on: 05-16-05 07:15

#12 @anonymousbugger
13 years ago

I have the same problem: default install, and just an blank page when trying to leave a message: http://weblog.unitedstatesofpeter.com

#13 @anonymousbugger
13 years ago

My blog has the same problem, which occured spontaneously and wasn't fixed with an upgrade to the stable 1.5.1 (I was using a 1.5 nightly from January or so previously, which had worked fine up to that point). In inexpertly attempting to apply tlongren's method I broke my blog, but I can fix that (and that'll learn me to mess with the code pre-coffee), not just at present though, since I'm at a remote location and don't have direct access to the directories.

#14 @doggie2
13 years ago

the unitedstatsofpeter comment was mine: I tried to apply the tongren solution but is it didnt do anything, not even a crash :). I was looking in the code and wp_comments_post ends with

$location = get_permalink($comment_post_ID); header("Location: $location");

And then nothing: what is it suppossed to do when there is no comment created?? I guess this permalink will be empty! The data does not et inserted in the database I checked.

BTW this isue is marked as a MINOR issue: I think it is a MAJOR issue, blogging is for a part about commenting and that doesnt work.

PLease help us!!!

#15 @Denis de Bernardy
13 years ago

Interesting idea... If $comment_post_ID is absent, then you could arguably get a blank page indeed.

i tried posting a comment via the url directly, to http://randomo.ocel.co.uk (=> blank screen) and to http://unitedstatesofpeter.com/weblog/ (=> Error: This file cannot be used on its own)

#16 @anonymousbugger
13 years ago

Strangely enough my comments seem to have randomly fixed themselves now?!

On http://randomo.ocel.co.uk

I haven't changed anything whatsoever!

#17 @anonymousbugger
13 years ago

Still busted, I installed 1.5.1 hoping it would fix this error, but no matter what browser I use, a blank page still appears when a comment is submitted.

#18 @anonymousbugger
13 years ago

I had the same problem running WP 1.5.1. Oddly enough, it didn't start until a week or so after upgrading to 1.5.1. Then I installed Spam Karma 2 beta 2, and then all comments were redirected to wp-comments-post.php. I went back to 1.5 with this blog, and all was well again.

However, another WP 1.5.1 blog I am running started the problem almost immediately after upgrading.

#19 @dougal
13 years ago

Those of you having problems: can you attach the contents of your 'comment moderation' and 'comment blacklist' lists? Cut-n-paste them into a text file with *no edits*, and attach the file here.

#20 @Denis de Bernardy
13 years ago

my lists are both blank. not even a \n or a \r

#21 @dougal
13 years ago

Hrm. So much for that idea, then.

#22 @anonymousbugger
13 years ago

I was the poster 05-17-05 16:04; my comments fixed themselves as well, with no effort on my part. I guess it makes as much sense that it spontaneously fixed itself as that it spontaneously broke. Weird, though. Does it have to do with date formatting or something bizarre like that? That's the only thing that actually changed.

#23 @MC_incubus
13 years ago

Comments appear to be working at these sites:

http://unitedstatesofpeter.com/weblog/ http://www.ocel.co.uk/randomo/ (says it fixed itself) http://www.longren.org/

Can we just attribute this to funky server issues? At least one person said it started happening with no change on their part, and then fixed itself.

#24 @Denis de Bernardy
13 years ago

Possibly. I suggest you leave the bug open nonetheless and label it 'the mysterious blank comment page bug' until someone figures out where it might come from. I've at least three users who experienced problems on my own server. Best I know is many users are commenting on the blog. But these very few users got errors systematically -- which led me to believe a user config problem could be causing it, rather than a server config.

#25 @anonymousbugger
13 years ago

Hey, my (jrbutler) comments are still busted. I have nothing in either of the my moderation or black list, they are both blank.

Since I didn't change anything before my feature busted, and upgrading from 1.5 to 1.5.1 didn't fix it, is it safe to assume that maybe it is a server side problem? I am hosted by dreamhost, and I noticed someone else had with this issue was also on dreamhost.

#26 @anonymousbugger
13 years ago

I found IT. When you have a redirect on your server like me (http://weblog.unitedstatesofpeter.com redirects the browser to http://unitedstatesofpeter.com/weblog ) and you have set in the options, the Blog address (URI) as the first mentioned URI then 2 things dont work: you cannot promote users, even if you do all the referrer stuff, and your comments go to a blank page. It is a bug I think because my users should be able to get linked all the time to weblog.uni.... . But OK. For me it works now!

#27 @anonymousbugger
13 years ago

Holy crap! That was totally it. My server was redirecting from www.hippobomb.com to hippobomb.com and I did not have that set in my URI options! I had www.hippobomb.com/blog which was incorrect... I changed it to hippobomb.com/blog and she's workin' fine now.

Great detective work! Thank you so much!

#28 @anonymousbugger
13 years ago

Turning off the WP SpamAssassin plugin fixed it for me.

#29 @SystemOfAJon
13 years ago

(I am the anonymousbugger that posted on 18 06:39:08 2005)

After 1.5.1.1 I hoped that this may have been fixed...but no. I upgraded my test blog to see if it would work, but it obviously didn't.

I have disabled all of the plugins and reverted back to the Default theme. The one variable here would be that I've turned the "privacy control" on Norton Internet Security off when testing it, or having it on.

For some reason or another, I have to turn it off to activate plugins or such (i.e., having referrers enabled). Now I have to do this when commenting too?

#30 @SystemOfAJon
13 years ago

WP 1.5.1.2 seems to have fixed this problem for me. :)

#31 @levak
12 years ago

  • Version changed from 1.5.1 to 2.0.3

For me, shutting down my firewall solved the problem. It seems like most FW are rejecting HTTP_REFERER.

Matej

#32 @ryan
12 years ago

2.0.4 should no longer require the referer. We need to test this case prior to final release.

#33 @bobbyg357
12 years ago

If you eneter a comment with no line space or new paragraph it previews and submits fine. If you try to format you comment by using your enter key </p> when you hit the preview button all text vanishes.

Running WP2.0.3 with a Neptune 0.9 theme.

http://www.npgop.org This is political site with non-tech viewers so this bug is a major problem for the forum.

#34 @bobbyg357
12 years ago

Did you fix my above mentioned bug in 2.0.4?

#35 @foolswisdom
12 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

bobbyg, there is a lot of info in this bug, but it sounds like your issue is different than the one originally described here. Please test in 2.0.4 (with detaul theme / out plugins) and open a new bug if still an issue.

Closing bug as WORKSFORME without testing, if original issue is still a problem, please reopen with detailed status update, or probably better to open a new bug referencing this one.

Note: See TracTickets for help on using tickets.