WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#11906 closed defect (bug) (invalid)

Bulk edit of pages always changes "Parent"

Reported by: jstarko0329 Owned by:
Milestone: Priority: normal
Severity: major Version: 2.9.1
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

When bulk editing several pages, it is not possible to edit the pages without changing the parent setting. In other words, a "-No Change-" option is missing.

For example, if my setup is:

Parent 1
-Sub 1.1
--Sub 1.1.1

Parent 2
-Sub 2.1
--Sub 2.1.1

If I bulk edit pages pages 1.1, 1.1.1, 2.1, and 2.1.1, it is impossible to leave the parent setting at "No Change." Instead, I am forced to select a new parent page, thus destroying my hierarchy.

Change History (4)

comment:1 @scribu5 years ago

  • Milestone changed from Unassigned to 3.0

comment:2 @nacin5 years ago

  • Keywords reporter-feedback added; bulk edit parent removed

Cannot reproduce on 2.9.1 or trunk. I'm getting a "- No Change -" option. It definitely exists in core, I can see it in wp-admin/includes.php on line 1131 (on trunk) and 1128 (in 2.9.1).

Perhaps a plugin is mucking with this via the quick_edit_dropdown_pages_args filter?

comment:3 @rfair4045 years ago

I too can not seem to duplicate this issue, running trunk 12794 and am able to bulk edit pages without changing parent.

comment:4 @nacin5 years ago

  • Milestone 3.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing pending reporter feedback. I'm betting it's a plugin attached to the filter.

Note: See TracTickets for help on using tickets.