WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#11924 closed defect (bug) (duplicate)

r12732 breaks plugin(s) that check(s) if $wp_version is set

Reported by: demetris Owned by: westi
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Plugins Keywords:
Focuses: Cc:

Description

After r12732 (about which see #11881) the PHP Markdown Extra plugin stopped working. I looked at the plugin’s code, and saw that it only does its thing (adding/removing filters) after checking if isset($wp_version) — which, apparently, returns FALSE after r12732.

Conversation about the issue from the wp-dev channel:

(2:19:59 PM) demetris: I use a plugin that loads if (isset($wp_version)), and it stopped loading after r12732.
(2:20:03 PM) wp-trac-bot: demetris1: http://core.trac.wordpress.org/changeset/12732
(2:20:42 PM) demetris: I would open a ticket, but I dont know where the issue is, or whether it is just sth temporary because of the shuffling around.
(2:21:24 PM) westi|gone: demetris1: I suspect that is because plugins are no longer loaded in global scope
(2:21:43 PM) westi|gone: probably best to put a note on the ticket which changed the behaviour
(2:21:49 PM) dd32: westi|gone: now thats going to have some... MANY issues..
(2:22:18 PM) demetris: Thanks westi|gone.  I'll add a note on the ticket.
(2:22:21 PM) westi|gone: dd32: probably... can't remember if the activation test code runs in global scope though
(2:22:40 PM) westi|gone: dd32: we may have to undo some of these changes... 
(2:22:45 PM) demetris: By the way, the plugin is PHP Markdown Extra (which is the one WP plugin I cannot live without).
(2:22:45 PM) dd32: westi|gone: No it doesnt, Its held inside a function. 
(2:23:08 PM) westi|gone: demetris1: worth putting that info in your comment on the trac ticket
(2:23:28 PM) demetris: westi|gone: OK.  Thanks!

Change History (4)

comment:2 miqrogroove4 years ago

  • Cc miqrogroove@… added

comment:3 nacin4 years ago

  • Milestone 3.0 deleted

A side effect not considered. Let's mark this as a duplicate of #11881 and handle it there? I've posted ideas there on how we can fix this.

comment:4 dd324 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

See #11881

Note: See TracTickets for help on using tickets.