WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 months ago

Last modified 10 months ago

#11931 reopened enhancement (worksforme)

Day/Month/Year Permalink Structure Fails in Archives — at Version 4

Reported by: Frenzie Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.6
Component: Rewrite Rules Keywords:
Focuses: Cc:
PR Number:

Description (last modified by danielbachhuber)

If you use a permalink structure with %day%/%monthnum%/%year% then the archives automatically become date/%day%/%monthnum%/%year%. WordPress automatically makes the links to monthly archives date/01/2010 etc (which is good), but if you go to it you get a 404 not found.

Reproduce using for example /%post_id%/%postname%/%day%/%monthnum%/%year%/

I "fixed" it with this plugin I wrote, but it will probably fail when things like /page/2/ come into play (that wasn't really important yet).

Change History (9)

#1 @nacin
10 years ago

  • Keywords needs-patch added; permalink day/month/year removed
  • Milestone changed from Unassigned to Future Release
  • Type changed from defect (bug) to enhancement

#2 @ryan
6 years ago

  • Owner ryan deleted
  • Status changed from new to assigned

#3 @chriscct7
4 years ago

  • Keywords needs-testing added

#4 @danielbachhuber
10 months ago

  • Description modified (diff)
  • Keywords needs-patch needs-testing removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

I tried and was unable to reproduce this issue in WordPress 5.2

When I set my permalink structure to /%post_id%/%postname%/%day%/%monthnum%/%year%/, my blog post loaded as expected at http://wordpress-develop.test/1/testing-a-new-draft/05/04/2019 and I was able to access a date archive at http://wordpress-develop.test/date/05/04/2019 as expected.

Feel free to re-open if there are other steps that reproduce this issue.

Note: See TracTickets for help on using tickets.