WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 months ago

#11942 closed enhancement (duplicate)

Use JS Calendar control for date picking

Reported by: sirzooro Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: UI Keywords:
Focuses: Cc:
PR Number:

Description

There are few places in WordPress when it allows to enter date, e.g. date of scheduled post. Now we have to enter day, month and year using three fields. It will be much easier to select date using calendar control. I think that this jQuery-based Datepicker looks good.

BTW, along with this Datepicker control there are few more JS widgets - Accordion, Dialog, Progressbar, Slider and Tabs. I think they can be useful too (especially for plugin authors).

Change History (12)

#1 @azaozz
10 years ago

Judging from our experience with jQuery UI (and the tickets proposing to replace it) don't think it would be a good idea to add this to the Edit Post screen. It's a big script that has some quirks and IMHO doesn't make the UI or UX much better.

#2 @nacin
10 years ago

  • Milestone changed from 3.0 to Future Release
  • Owner changed from azaozz to jane
  • Status changed from new to assigned

Moving to future release and assigning Jane for a UX review. If she's not sold on the idea, we should go right to wontfix.

#3 @scribu
10 years ago

A datepicker is a lot easier to use than the current 3 inputs method.

Perhaps we can find a more lightweight implementation than the one from jQuery UI.

#4 @scribu
10 years ago

  • Component changed from JavaScript to UI

#5 @jane
10 years ago

Personally, I'd love a calendar picker, since a lot of people using future publish don't remember which date as much as which day (next Saturday, etc), but I defer to Andrew. If the code is not desirable, I'm totally happy with this just being a plugin. The ability to set a future publish date is the basic feature and belongs in core; fancier ways of date selection are fine to keep in plugins.

#6 @jane
10 years ago

  • Owner changed from jane to azaozz

#7 @scribu
10 years ago

Hm, the plugin approach makes sense. I'll post here after I whip up one.

#8 @dahamsta
9 years ago

+1 for a proper date picker, scheduling is incredibly awkward at the moment.

Please merge with #7665

Last edited 9 years ago by scribu (previous) (diff)

#9 @nacin
9 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

#10 @dahamsta
9 years ago

Thanks

#11 @herbertwest1
17 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hello,

In 2018, couldn't please reconsider not having a UX calendar in the core Wordpress in order to chose the publication date instead of manually putting a date?
I personnally believe that it's a lot better and easier for users to see which DAY their post will be programmed for : not specifically a date, but also knowing that it will be on a tuesday, will help the editorial decisions.

Thanks !

#12 @desrosj
9 months ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

Hi @herbertwest1!

I am going to close this ticket out again. It's still a duplicate of #7665, and as the response to you there indicates, with the introduction of the new block editor there is now a calendar date picker for selecting post dates.

Note: See TracTickets for help on using tickets.