WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#11979 closed defect (bug) (worksforme)

After r12794 install by uploading fails for one ZIP archive (works for others)

Reported by: demetris Owned by: dd32
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:

Description

Here is the story:

I upgraded John Godley’s Search Regex and there was an issue, so I looked for an earlier version to go back to. Finding nothing in WP/Extend, I downloaded v1.4.9 from the plugin homepage:

http://urbangiraffe.com/plugins/search-regex/

r12794 gives me this error during installation:

Installing Plugin from uploaded file: search-regex.zip

Unpacking the package…

Warning: ftp_mkdir() [function.ftp-mkdir]: Create directory operation failed. in /[...]/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php on line 248

Could not create directory. /public_html/wp-content/upgrade/search-regex/search-regex/view/admin

Going back to r12793 solves the problem. Confirmed on two different setups.

Also, the problematic ZIP extracts fine on my Windows desktop, and on the two Linux servers of the two WP setups (Debian and CentOS).

Attachments (1)

fs-logger.php (16.9 KB) - added by dd32 10 years ago.

Download all attachments as: .zip

Change History (8)

#1 @dd32
10 years ago

  • Status changed from new to accepted

Also, the problematic ZIP extracts fine on my Windows desktop, and on the two Linux servers of the two WP setups (Debian and CentOS).

By that, You mean on your desktop, Not on WordPress installs on that server, Right?

#2 @demetris
10 years ago

Sorry, that wasn’t clear.

After the install via the WP interface failed, I tried this, as an alternative way to install the plugin and also to see if any of the Linux servers would complain about the ZIP archive:

  1. Logged in via SSH
  2. cd to wp-content/plugins
  3. wget ARCHIVE-URL
  4. unzip ARCHIVE-NAME

Which worked in both servers.

Also note that the WP interface works OK for plugins I download to my desktop from WP/Extend, and also for search-regex.zip from WP/Extend. The problem after r12794 only occurs for search-regex.zip downloaded from urbangiraffe.com.

#3 @dd32
10 years ago

Also note that the WP interface works OK for plugins I download to my desktop from WP/Extend, and also for search-regex.zip from WP/Extend. The problem after r12794 only occurs for search-regex.zip downloaded from urbangiraffe.com.

Thanks for that.

I've tried both the urbangiraffe.com .9 package, its .10 package, and the latest (.10) from WP Extend, and they're all working correctly for me.

I'm going to attach a Logging class i use for issues like these, Just drop it into /wp-content/mu-plugins/ and attempt the install of a plugin, it'll fill the screen with a lot of info about the calls made to the filesystem (Note, that they will not be in a clear order as to whats what). If you could get that debug text to me (wordpress [a t] dd32.id.au will do) I might be able to spot what isnt working as expected for you.

@dd32
10 years ago

#4 @dd32
10 years ago

attachment fs-logger.php added

Just a note for that, That version is only for those who are using the FTP Extension (As the reporter here is). Please dont use it to report just any error to me, its only needed if asked for.

#5 @dd32
10 years ago

  • Keywords reporter-feedback added

I havnt been able to reproduce this yet, nor seen any other reports of this.

#6 @dd32
10 years ago

I've put a request out on the wp-testers mailing list asking if anyone is having difficulties which could be related.

#7 @dd32
10 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from accepted to closed

Closing as worksforme for now. I cant reproduce this, and i havn't found anyone who can.

This may have been due to a filesystem(or ftp server) security/file locking mechanism..

Feel free to re-open if you are affected by this (That is, a single ZIP which will ALWAYS fail on a server with a similar message, where other Zip's pass fine)

Note: See TracTickets for help on using tickets.