Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#12010 closed enhancement (invalid)

Insert Audio with FILE URL does not work correctly

Reported by: wpmuguru Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.4
Component: Multisite Keywords: reporter-feedback
Focuses: Cc:


MU Trac Ticket: http://trac.mu.wordpress.org/ticket/958

When inserting audio into a page with the File Url option the result is: <a href=" http://jmcginnis.bandzilla.net/files/2009/04/03-plateau.mp3" rel='attachment wp-att-20'>Plateau</a>

After a save the result is: <a href=' http://jmcginnis.bandzilla.net/home/03-plateau/' rel='attachment wp-att-20'>Plateau</a>

As you can see it turns into a attachment link.

Change History (8)

comment:1 @wpmuguru6 years ago

Can someone confirm whether this is still a problem?

comment:2 @wpmuguru6 years ago

  • Keywords needs-feedback added

comment:3 @freddyware6 years ago

  • Type changed from defect (bug) to enhancement

I am pretty sure this is the intended behaviour. What is WordPress supposed to do with audio files, embed them?

comment:4 @wpmuguru6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Works ok in trunk. Closing pending someone having an issue.

comment:5 @nacin6 years ago

  • Keywords reporter-feedback added; needs-feedback removed
  • Milestone Unassigned deleted

comment:6 @nacin6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 @nacin6 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Re-open with steps to reproduce any unintended behavior.

comment:8 @jkershner5 years ago

Resolved in 2.9.2

Note: See TracTickets for help on using tickets.