Make WordPress Core

Opened 14 years ago

Closed 9 years ago

Last modified 4 years ago

#12030 closed enhancement (wontfix)

Better Options for New Registrations

Reported by: wpmuguru's profile wpmuguru Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords: needs-patch
Focuses: multisite Cc:

Description (last modified by scribu)

MU Trac Ticket: http://trac.mu.wordpress.org/ticket/872

At the moment when new users register, there are very few options and not many plugins available.. It would be nice if the administrator could :

1) Allow passwords to be set during registration, rather than having it sent by email.

2) Make Email Verification optional.

3) See the users who haven't confirmed their registrations, and resend the confirmation emails from the admin area..

4) User Moderation : Make it easier to kick out users and delete spammers..

5) Invitation Codes (Optional): Allow the admin to create invite codes, which he can distribute, so that the mu install is well knit social community.

I know this is pretty much doable, but there lacks any good solution at the moment.

Change History (13)

#1 @wpmuguru
14 years ago

  • Type changed from defect (bug) to enhancement

This would also apply to a single site install. I've put it under the multisite component because it came from MU trac.

#2 @wpmuguru
14 years ago

  • Milestone changed from Unassigned to Future Release

#4 @scribu
13 years ago

  • Description modified (diff)

#5 @SergeyBiryukov
13 years ago

  • Keywords needs-patch added

#6 @wpte
12 years ago

I'd like to know if this thing is going to be fixed any time soon.
I've previously made a similar ticket at the BP trac: http://buddypress.trac.wordpress.org/ticket/4133

I seriously like to see this feature quite soon

#7 @scribu
12 years ago

I think this is the kind of thing that would get commited fairly quickly if someone (not on the core team) actually took the time to write a patch.

#8 @NickMackz
12 years ago

When I have the time during the summer, I am very tempted to look into this in more detail.

I have never done PHP properly before, other than making some basic improvements / updates to a few plugins, so I would have some learning to do. I can program in VB, Java, and C so I'm sure I could pick it up fairly fast.

Currently I've updated the BP-Registration-Options plugin to do this, but it would be great to have it as a proper WP feature. I've also got the problem that BP-Registration-Options is only accessible to admins and I would like my moderators to be able to approve new members.

Last edited 12 years ago by NickMackz (previous) (diff)

#9 @DrewAPicture
12 years ago

  • Cc xoodrew@… added

#10 @martythornley
11 years ago

  • Cc marty@… added

#11 @jeremyfelt
11 years ago

  • Component changed from Multisite to Login and Registration
  • Focuses multisite added

#12 @chriscct7
9 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

From the original ticket:

  1. Is the exact opposite of how WordPress is heading in terms of password security

2-5 Plugin territory and there are many existing plugins that do these things.

Given that and the lack of activity over the last 3 years closing as wontfix. Individual items should be opened as their own trac ticket (having 6 features on a single ticket isn't very helpful)

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.