WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 8 months ago

#12043 closed enhancement (invalid)

Infinite redirect if using a port number

Reported by: wpmuguru Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Multisite Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

MU Trac Ticket: http://mu.trac.wordpress.org/ticket/189

While setting up my new blog I found that WordPress? MU continuously re-directed me to the same URL (occurs in the if statement on line 9 of wp-signup.php). This was being caused by wpmu-settings.php on line 10. The variable $domain has the port stripped from it, which causes line 84 to return no result when it queries the database.

WP MU is installed at http://some.host.address:8080/blogs on my machine. VHOST is false.

Change History (3)

comment:1 solarissmoke2 years ago

  • Keywords close added

I can't reproduce the infinite redirect - having a port number just causes WP to die with "Multisite only works without the port number in the URL."

comment:2 SergeyBiryukov2 years ago

  • Description modified (diff)

comment:3 jeremyfelt8 months ago

  • Keywords close removed
  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version set to 3.0

The original issue reported on this ticket is resolved. An error message is displayed rather than a redirect. See #15936 for a related ticket dealing with IPv6 support.

Note: See TracTickets for help on using tickets.