WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12062 closed enhancement (duplicate)

edit-tags.php add_tag_form_fields hook

Reported by: jfarthing84 Owned by: dd32
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Administration Keywords:
Focuses: Cc:

Description

There is a hook for add_tag_form_pre and add_tag_form (which is fired after the the form). I believe a 'add_tag_form_fields' hook should be added as well, just like in the edit-tag-form.php file. This is so plugins can add custom fields for custom taxonomies. While on the subject, it would be nice for all the fields and buttons on the custom taxonomy page to display the taxonomy name instead of "Tag" (ie. "Add A New Tag" or "Tag Name".

Change History (3)

comment:1 jfarthing844 years ago

  • Cc jfarthing84@… added

comment:2 dd324 years ago

  • Keywords dev-feedback removed
  • Milestone changed from Unassigned to 3.0
  • Owner set to dd32
  • Status changed from new to accepted

While on the subject, it would be nice for all the fields and buttons on the custom taxonomy page to display the taxonomy name instead of "Tag" (ie. "Add A New Tag" or "Tag Name".

See #11838 - I've merged categories into the edit-tags form, so that'll get fixed shortly in trunk.

I'll also need to fix up and standardise the hooks provided, so will address this in that.

comment:3 dd324 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from accepted to closed

Duplicate of #11191

(In [12941]) Migrate Category Edit UI hooks, Standardise on custom-taxonomies hooks, add custom-fields for taxonomies UI hooks. See #11838, Fixes #11191

Note: See TracTickets for help on using tickets.