WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12079 closed defect (bug) (duplicate)

Sort order and page navigation

Reported by: nagaju Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.9.1
Component: General Keywords:
Focuses: Cc:

Description

If I browse in specific category, there are page navigation links that correctly shows newer and older entries. But... When I use reverse order (?orderby=date&order=asc) link to "NEWER entries" show OLDERS and vice versa.

You can check at:
http://wordpress.org/development/?orderby=date&order=asc

At he bottom page there is link: "Older posts", but it will show newer posts (there are no older posts).

Change History (2)

comment:1 scribu4 years ago

  • Keywords close added
  • Milestone changed from Unassigned to Future Release

The issue is that the wording isn't reversed.

Since there are two independent functions involved - previous_post_link() and next_post_link() - I don't see how this could be solved.

comment:2 nacin4 years ago

  • Keywords sort navigation close removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.