WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 21 months ago

#12093 closed defect (bug) (worksforme)

Default value in uploads folder is constantly wrong

Reported by: dokueki Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Upload Keywords: reporter-feedback
Focuses: Cc:

Description

I've installed my share of WordPress blogs (around, 8? 10?) and I've always had the following problem:
The default value in the option for default upload directory is always the URL of the blog + wp-content/uploads instead of just wp-content/uploads. This results in a directory called 'http:' in the root directory of WordPress, with another empty name directory in it ('/'), and another one inside, ('/') -- for the http:// part, and then for whatever path the blog is in, would split the URL and create the directory (for example, http://mysite.com/blog would result in http:/, /, /, mysite.com/, blog/ directories.

It happens all the time for me when installing WordPress. By the time I fix it myself, I already have that directory on my server and it's hard to delete it because of the empty-names in the dirs and the : in the root dir.

Change History (2)

comment:1 dd324 years ago

  • Keywords reporter-feedback added; upload directory invalid default removed

Few quick questions

Are the installs on the same host?

All linux? Or windows too (servers i mean)

Same Home url as site url? (ie.WordPress is not installed in a subdir as such: home could be mysite.com/ and siteurl could be mysite.com/wordpress/wp-admin/ etc)

Do you know what PHP versions are in use? What about if safe_mode is enabled? or open_basedir?

comment:2 nacin21 months ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Re-open with steps to reproduce.

Note: See TracTickets for help on using tickets.