WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#12116 closed defect (bug) (duplicate)

Calendar output does not pass HTML5 validation

Reported by: iammattthomas Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords: has-patch
Focuses: Cc:

Description

Because of a summary attribute on the table element, and abbr attributes on the th and td elements, the output of get_calendar fails if the theme is HTML5. Since the new default theme with 3.0 is in HTML5, this would be a good fix to go with it.

Attachments (1)

12116.2.patch (2.0 KB) - added by iammattthomas 6 years ago.
Patch removes summary attribute from calendar table element, abbr attributes from calendar th and td elements.

Download all attachments as: .zip

Change History (4)

@iammattthomas6 years ago

Patch removes summary attribute from calendar table element, abbr attributes from calendar th and td elements.

comment:1 follow-up: @nacin6 years ago

  • Milestone 3.0 deleted

Duplicate of #11554. Move the patch and continue there?

comment:2 in reply to: ↑ 1 @iammattthomas6 years ago

Replying to nacin:

Duplicate of #11554. Move the patch and continue there?

Thanks -- I knew a similar ticket had to be there, but didn't find it in my search.

comment:3 @iammattthomas6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.