WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12148 closed enhancement (fixed)

Warning by is_readable() in class-phpass.php

Reported by: ocean90 Owned by: westi
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Warnings/Notices Keywords: has-patch
Focuses: Cc:

Description

After install I get this message

Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(/dev/urandom) is not within the allowed path(s): (/var/www/web31/html/:/var/www/web31/phptmp/:/var/www/web31/files/:/var/www/web31/atd/) in /var/www/web31/html/blog/wp-includes/class-phpass.php on line 58

If I want to change then the password I get the typical
Warning: Cannot modify header information message.

Maybe we should add an @ before is_readable('/dev/urandom')

Attachments (1)

class-phpass.php.diff (421 bytes) - added by ocean90 4 years ago.

Download all attachments as: .zip

Change History (5)

ocean904 years ago

comment:1 sivel4 years ago

  • Keywords has-patch added

comment:2 sivel4 years ago

See #12331 (which is likely a duplicate of this ticket)

comment:3 nacin4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [13429]) Suppress potential is_readable() warning. Fixes #12148 props ocean90

comment:4 hakre4 years ago

Related: #15088

Note: See TracTickets for help on using tickets.