WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#12187 closed defect (bug) (wontfix)

Editing another user's profile makes user_id to disappear

Reported by: Cimmo Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Users Keywords: profile
Focuses: Cc:
PR Number:

Description

This seems a regressions since 2.8.6, not sure if intended, anyway here the use case:

  1. login with admin (user_id=1)
  2. edit another profile (user_id!=1)
  3. remove email (not allowed)
  4. save changes

result:
$_GETuser_id?=1 instead of the id of the profile's user_id.

I know I can check for $_POSTuser_id? but why this change?

Change History (3)

#1 @Cimmo
10 years ago

Sorry I wanted to say:
$_GETuser_id? is absent, in WP 2.8.6 was present.

#2 @nacin
10 years ago

Sounds like this is related to #11222 #11271 [12288] [12267] [12300].

#3 @nacin
10 years ago

  • Milestone 2.9.3 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

False alarm, it's actually related to [11830]. Because it's receiving the user_id via POST, I'm inclined not to "fix" this again. The global $user_id will always contain the ID being edited.

Note: See TracTickets for help on using tickets.