WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12191 closed defect (bug) (wontfix)

Lowercase/Uppercase problem with categories and tags

Reported by: rootix Owned by: filosofo
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords: reporter-feedback
Focuses: Cc:

Description

Hi all

I think this is a bug in WordPress:

When i have the category "Technology" and then create a tag "technology" in a post, the "Technology" category change to lowercase like the tag.

The same problem at the tags. When i first use a lowercase tag, and then create a category with the same name, but uppercase, the tag is now also uppercase.

Both, categories and tags should be handled separated. It is not very practicable this way. My category list looks terrible.

Change History (3)

comment:1 @dd325 years ago

  • Component changed from General to Taxonomy
  • Keywords reporter-feedback added; dev-feedback removed
  • Owner set to filosofo

What version are you experiencing this under?

comment:2 @ryan5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Term slugs are canonical by design. This is a side-affect of that. Unfortunately, fixing this requires substantial redesign.

comment:3 @nacin5 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.