WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12243 closed defect (bug) (duplicate)

Taxonomy Checkboxes sync to any checkbox array on the edit form

Reported by: kevinB Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: General Keywords: taxonomy, category, post
Focuses: Cc:

Description

(see #12242 for corresponding WP 2.9 patch)

The javascript which syncs "All" and "Most Used" category checkboxes was rewritten for WP 2.9. The new JQuery code binds to the click event of every checkbox on the form, and synchronizes the category checkboxes with matching value attribute.

In the default configuration it works fine. But if a plugin adds another checkbox array to the form, these checkboxes also become a sync source for the category checkboxes. Category checkboxes are (un)checked when the plugin checkbox is clicked.

This occurs only with plugin-defined checkbox arrays, and only for checkboxes whose values attribute matches a category ID. So there is a limited incidence, but potentially significant severity. The error would presumably also occur with custom taxonomy checkboxes.

To reproduce:

  • Edit or Add New Post
  • In the Readers metabox, toggle the checkbox of a Group or User whose ID value matches any Category ID (Firebug is helpful here).

Change History (2)

comment:1 kevinB4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #12244

comment:2 nacin4 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.