WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12246 closed defect (bug) (duplicate)

Canoncial Crash With WP_DEBUG

Reported by: miqrogroove Owned by: westi
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Warnings/Notices Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Enable pretty permalinks.
  1. Enable WP_DEBUG.
  1. Hit /?cat=99999999

category-template.php fails on a NULL return from the Taxonomy API, then Canonical dies on headers.

Change History (4)

comment:1 @miqrogroove6 years ago

Tested with [13170] and it appears /?cat=99999999 no longer redirects or crashes, however the output now includes more than a dozen PHP Notices, and no obvious content. For clarity, I will close as a duplicate of the 404 consistency ticket.

comment:2 @miqrogroove6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 @miqrogroove6 years ago

  • Milestone 3.0 deleted

comment:4 @sivel6 years ago

related #10191

Note: See TracTickets for help on using tickets.