WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 12 months ago

#12260 closed feature request (duplicate)

Add PHP requirement to plugin info retrieved trough API call

Reported by: petervanderdoes Owned by: ryan
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords: close
Focuses: Cc:

Description

Setup:
Add a field to the header of the readme.txt
Example:
Requires at least PHP: 5.2

Use this field in the back end, to be returned when calling:
wp_remote_post('http://api.wordpress.org/plugins/update-check/1.0/', $options);
adding it to the transient 'update_plugins'.

Then when a plug-in upgrade is available and the plugin changed to require PHP5 with in the core the option to upgrade could be disabled with some info that the PHP version X is required and the server runs PHP version Y.

Using a check during the on activation hook means that during an upgrade of the plugin the old version is already removed and the user would have to download and install the previous version of the plugin.

Attachments (1)

patch.diff (2.1 KB) - added by petervanderdoes 4 years ago.
The patch required in teh core. the $r->required_php is made up of course.

Download all attachments as: .zip

Change History (8)

petervanderdoes4 years ago

The patch required in teh core. the $r->required_php is made up of course.

comment:1 petervanderdoes4 years ago

The patch is created on WordPress 2.9.2 BTW

comment:2 jdingman4 years ago

+1, I think this would be a great idea. helps give people a better user experience overall, in my opinion

comment:3 hakre4 years ago

Related: #13699

comment:4 nacin3 years ago

  • Milestone changed from Awaiting Review to WordPress.org site

This is going to be less relevant come 3.2 and PHP 5.2.

comment:5 nacin3 years ago

  • Keywords close added

comment:6 SergeyBiryukov13 months ago

Related/duplicate: #23880

comment:7 nacin12 months ago

  • Milestone WordPress.org deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23880.

Note: See TracTickets for help on using tickets.