WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#12277 closed defect (bug) (duplicate)

Test-Suite: Cross-Plattform portability: No Color Codes in Windows Shell

Reported by: hakre Owned by: westi
Milestone: Priority: normal
Severity: normal Version:
Component: Unit Tests Keywords: has-patch tested
Focuses: Cc:

Description

The Windows Shell does not provide any colors. Well to be more precise it does support colors but not the way PHPUnit_TextUI_ResultPrinter handles them.

A fix is to not output color-codes on windows.

Attachments (2)

12277.patch (581 bytes) - added by hakre 5 years ago.
Worked like a charm.
12277.phpunit.xml.patch (387 bytes) - added by mbijon 3 years ago.
Disables color codes for Windows, post-June 2012 testrunner

Download all attachments as: .zip

Change History (12)

@hakre5 years ago

Worked like a charm.

comment:1 @hakre5 years ago

  • Keywords tested added

Tested: I had run the suite with this patch applied on windows and it worked as intended.


Testsuite Windows Compability Related: #11867

comment:2 @nacin5 years ago

  • Milestone 3.0 deleted

Moving out of 3.0.

comment:3 @hakre5 years ago

Didn't you wanted to have unit-tests with WP 3.0? This patch would help to get things in order.

comment:4 @nacin5 years ago

They're not milestone-dependent... I'm just clearing the 3.0 report. We have a report now specifically for unit tests.

comment:6 @hakre5 years ago

  • Keywords needs-unit-tests added

comment:7 @hakre5 years ago

  • Keywords needs-unit-tests removed

comment:8 @hakre5 years ago

  • Summary changed from Increase Cross-Plattform portability of the Testsuite: No Color Codes in Windows Shell to Test-Suite: Cross-Plattform portability: No Color Codes in Windows Shell

comment:9 @nacin5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:10 @mbijon3 years ago

  • Cc mike@… added

This patch is not valid for disabling color codes in Windows after closing #42, in June 2012.

After June 2012, the fix is now to set colors="false" in the test suite's phpunit.xml. It's simple, a patch isn't really needed, but is attached for reference.

@mbijon3 years ago

Disables color codes for Windows, post-June 2012 testrunner

Note: See TracTickets for help on using tickets.