WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12290 closed feature request (duplicate)

Term taxonomy attachments

Reported by: jfarthing84 Owned by: filosofo
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Taxonomy Keywords: dev-feedback
Focuses: Cc:

Description

How cool would it be to associate an image, or any kind of attachment to a term/taxonomy? I could think of many uses for it, and even more people who would benefit from it. The good news is that it would be *pretty* simple to implement.

Right now, attachments use a status of "inherit", a post_type of "attachment" and "parent" for the post/page that it is attached to.

My proposal to add functionality to attach to a "term/taxonomy":

Use the same "inherit" status but create a new post_type of "taxonomy-attachment" and then obviously use the "post_parent" for the term_taxonomy_id.

Change History (4)

comment:1 scribu4 years ago

A better way to do it would be to add taxonomies to attachments. That way you could have an image "attached" to more than one term/taxonomy.

That was attempted in one of the projects of GSOC 2009:

http://gsoc2009wp.wordpress.com/rudolf-photo-albums/

comment:2 jfarthing844 years ago

That could get real complex. Because, while your at it, you might as well allow an image to be attached to more than one post/page as well...

comment:3 scribu4 years ago

It wouldn't add complexity, since that's what the taxonomy system was designed for: creating many-to-many relationships between terms and posts (of any type).

you might as well allow an image to be attached to more than one post/page as well...

Not really. As stated above, the taxonomy is for relating terms to posts, not posts to other posts.

comment:4 scribu4 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.