WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#12308 closed defect (bug) (duplicate)

files in wp-includes missing closing php tags

Reported by: washer Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: General Keywords: cron, missing php tags
Focuses: Cc:

Description

files in wp-includes missing closing php tags

Numerous files in the 2.9.2 'wp-includes' folder are missing closing php tags (cron.php, wp-cron.php, version.php, etc).

Change History (3)

#1 @Lazy79
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

The closing tag of a PHP block at the end of a file is optional, and in some cases omitting it is helpful when using include() or require(), so unwanted whitespace will not occur at the end of files, and you will still be able to add headers to the response later. It is also handy if you use output buffering, and would not like to see added unwanted whitespace at the end of the parts generated by the included files.

taken from http://nl2.php.net/language.basic-syntax.instruction-separation

#2 @nacin
8 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#3 @nacin
8 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #12307.

Note: See TracTickets for help on using tickets.