WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12312 closed defect (bug) (duplicate)

Category tree gets mangled in the edit post page for categories with parents

Reported by: archon810 Owned by: filosofo
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Taxonomy Keywords:
Focuses: Cc:

Description

This might be solved in 3.0, I'm not sure, but please consider this case.

  • you have threaded categories, such as Phones -> HTC -> Hero, Phones -> HTC -> Sprint Hero. These show up correctly, threaded, in the edit post page, when none of them are selected.
  • now, if you check the box next to HTC and refresh the edit post page, the category tree is now destroyed because the checked categories get pushed up to the top. The problem is, that effectively normalized all subtags and pushes them to look like level 1 tags.

See this screenshot (the top part is before I pressed Update): http://i.imgur.com/a4DLn.png

Thank you.

Change History (4)

comment:1 dd324 years ago

  • Milestone changed from Unassigned to Future Release

That was a design choice, to float the selected terms to the top of the list.

It remains the same in 3.0.

Personally, I've never seen a great use of it, However, Can see why some people with many categories would find it useful, This way they can see the categories without scrolling through the entire list in order to find what its attached to.

comment:2 archon8104 years ago

I can kind of see use for it, especially for blogs with many categories, but it would be a lot better if the tree was preserved, IMO.

Whether that can be done while keeping the checked items pushed to the top or not is a UI design question.

Alternatively, the UI can have a little toggle that would switch between the current approach and the one with the tree fully intact.

comment:3 archon8104 years ago

  • Cc admin@… added

comment:4 scribu4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.