WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 21 months ago

Last modified 21 months ago

#12322 closed defect (bug) (worksforme)

Blog import fails to generate reduced-size images

Reported by: daveabrahams Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Import Keywords:
Focuses: Cc:

Description

I just imported from http://daveabrahams.wordpress.com (go ahead, try it yourself if you like) and chose to "Import Attachments." The only images from the original site that show up in the result are those that were originally displayed with size-full. The others need to be regenerated by inserting them freshly.

Change History (10)

comment:1 @daveabrahams5 years ago

Actually the problem is that the URL syntax is different. The imported URL is:

path/to/image/file?w=width-of-image

and the required URL syntax is

path/to/image/file-HDIMxVDIM.jpg

This seems difficult to work around at best

comment:2 @daveabrahams5 years ago

Looks like the fix needs to be made somewhere around tags/2.9.2/wp-admin/import/wordpress.php#L651 but now my expertise is exhausted. Would really appreciate a fix or this importing business is going to be painful.

Thanks.

comment:3 @daveabrahams5 years ago

  • Keywords import added

comment:4 @scribu5 years ago

  • Keywords changed from image,size,import to image size import
  • Milestone changed from Unassigned to 3.0
  • Severity changed from major to normal

In the meantime, you could use the Regenerate Thumbnails plugin.

comment:5 @ryan5 years ago

  • Milestone changed from 3.0 to 3.1

comment:6 @nacin5 years ago

  • Keywords reporter-feedback added; image size import removed
  • Milestone changed from Awaiting Triage to Awaiting Review

Still an issue? Looks like a wp.com issue?

comment:7 @dd324 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to WordPress.org

comment:8 @duck_3 years ago

  • Keywords close added

This mostly worksforme when testing with the theme test data. All resized images show up correctly in post content. However, it relies on browser resizing of the full size image, e.g.

<img src="http://wp.dev/wp-content/uploads/2010/08/boat.jpg?w=300" alt="" title="boat" width="300" height="198" class="size-medium wp-image-544">

All images have their resized equivalents created and saved to disk, e.g. boat.jpg, boat-150x150.jpg and boat-300x198.jpg.

comment:9 @c3mdigital21 months ago

  • Keywords reporter-feedback needs-testing close removed
  • Resolution set to worksforme
  • Status changed from new to closed

comment:10 @SergeyBiryukov21 months ago

  • Milestone WordPress.org deleted
Note: See TracTickets for help on using tickets.