Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12352 closed defect (bug) (fixed)

upgrade claims my DB needs repair

Reported by: ipstenu Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Multisite Keywords:
Focuses: Cc:


I tried upgrading my 3.0-alpha multisite install to the latest trunk and it tells me I'm missing DB tables and my site needs a repair. If I run the repair, it creates a new wp_options table and gets all broken on me, like it's ignoring that I'm using ms.

Checked out revision 13337.

I don't know the version I have right now, but I checked it out from trunk at about 10am ET on Feb 16th.

Change History (6)

comment:1 @nacin6 years ago

[13337] fixed a bug relating to tables in multisite. I can't produce anything else here. Can you provide any more info?

comment:2 @ipstenu6 years ago

Probably, but I'm not sure what more-info you want.

My site was a single WP, upgraded to 3.0, turned on Multi-Site, imported two blogs, made Blog #3 the Main Blog, and it's working fine right now. I have wp_2_* and wp_3_* tables right now, no wp_1_*

It's installed in the /wp folder

I uploaded the new files, and my site said it couldn't reach the DB. I went to the admin side, it wanted to repair. I ran repair and it created wp_options (which does not exist) and my blog was no longer available. If I went to /wp/blog, it told me /wp/wp/blog didn't exist.

comment:3 @ipstenu6 years ago

Okay, I went to re-run it again, just to screenshot, and [13352] does NOT have the same error... In fact, it was so smexy I wanna wear WP earings.

comment:4 @nacin6 years ago

Excellent. I was beginning to wonder if we were not properly accounting for a change in the main blog somewhere.

comment:5 @ipstenu6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I'm going to assume something magically fixed it between then and now, or that the patient application of coffee to my brain had me do something different :)

comment:6 @nacin6 years ago

  • Milestone changed from Unassigned to 3.0

My guess is you had checked out just before r13337, as it was committed only 15 minutes before you created this ticket.

Note: See TracTickets for help on using tickets.