WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12361 closed defect (bug) (duplicate)

url chars stripping

Reported by: unsalkorkmaz Owned by: hakre
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Charset Keywords:
Focuses: Cc:

Description

When i try to set permalinks to russian chars, there is no problem.
for example changing about page permalinks to примерно

But when i try to change permalinks to turkish chars, wordpress strips those characters. Why? Is it bug? if its not a bug, this is a big issue about being international.
tried those chars:
şŞ
İı
Ğğ
Üü
Öö
çÇ

Change History (11)

#1 @unsalkorkmaz
9 years ago

  • Milestone set to 3.0

#2 @unsalkorkmaz
9 years ago

  • Keywords needs-patch added

#3 follow-up: @hakre
9 years ago

When i try to set permalinks to ... - Please specify steps to reproduce. Where do you set those permalinks?

Did you change the default encoding settings?

#4 follow-up: @unsalkorkmaz
9 years ago

i cant believe you didnt read this.
well.. just enter ANY page / post whatever. try to set permalinks to şŞ İı Ğğ Üü Öö çÇ

example screenshot:
http://www.unsalkorkmaz.com/turkishurl.jpg
after edit:
http://www.unsalkorkmaz.com/turkishurl2.jpg

#5 in reply to: ↑ 4 ; follow-up: @nacin
9 years ago

Replying to unsalkorkmaz:

i cant believe you didnt read this.

I'm not sure attacking a core contributor is going to solve your problem.

#6 in reply to: ↑ 5 @unsalkorkmaz
9 years ago

Replying to nacin:

Replying to unsalkorkmaz:

i cant believe you didnt read this.

I'm not sure attacking a core contributor is going to solve your problem.

I am soo sorry if it means attacking to you. Just i believe i explain enough good. Again sorry if it means any harm to you or hakre. Ofc i am just trying to help wordpress community like you guys

#7 in reply to: ↑ 3 @unsalkorkmaz
9 years ago

Replying to hakre:

Did you change the default encoding settings?

no didnt change anything. its latest trunk 3.0-alpha. default setup, default theme. 0 plugin

#8 @hakre
9 years ago

  • Keywords needs-patch removed
  • Milestone 3.0 deleted
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for reporting and providing the additional information. Now I can better better understand the issue.

What you describe is known and sort of by design / by dataflow and not certain to change because it would break how exsiting sites resolve title. Infact, a similar issue has already reported some time ago: #9492. Within that ticket more information is available.

I suggest you get in contact with the turkish wp community and discuss what it's done to work around the issue already today. I can imagine that there is some sort of plugin that might ship with a translation that does this already but I do not know.

Take a look for the sanitize_title filter. To that one code is attached by default that will cause the problem you report. Create a plugin that removes the default sanitzer and add your own that properly handles turkish chars.

The information in the last paragraph comes with no warranty.

I will close this issue as duplicate now. Feel free to add further comments to it or to the original report in #9492.

#11 @hakre
9 years ago

Related: #9591

Note: See TracTickets for help on using tickets.