Changes between Initial Version and Version 1 of Ticket #12371
- 02/25/10 16:41:42 (7 years ago)
- Property Summary changed from Generalize get_generic_template()'s logic (and improve its name) to Change get_generic_template's name
initial v1 1 There are two, mostly independent parts of this patch: 2 * Logic changes to `get_generic_template` 3 * Name change of `get_generic_template` (to `get_specific_template`) 4 5 '''Logic Changes''' 6 * `get_generic_template` is basically meant to allow someone to request a series of preferred templates, from specific to general. 7 * Patch generalizes the idea to an indefinite number of slugs, expanding its usefulness. 8 * E.g.: `get_specific_template('index', 'archive', 'category', 'category-slug');` (Obviously the particular logic of this example is handled already by core, but I mean to make it available for theme-specific, parallel ideas). 9 10 11 '''Name Change''' 12 1 * `get_generic_template` needs a better name, because its purpose is to get a ''specific'' template. Even the original documentation recognizes this (emphasis mine): 13 2 * "if a name is ''specified'' then a ''specialised'' template will be included."