WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 months ago

#12393 closed enhancement (duplicate)

Hooks to enable custom login without editing core files

Reported by: sleepuser Owned by:
Milestone: Priority: low
Severity: normal Version: 2.9.2
Component: Users Keywords: needs-patch login custom core files
Focuses: Cc:

Description

One of the basic features of wordpress is to avoid having users edit core files.
It is impossible to properly customise wp-login without manually editing the file directly - not good for upgrades!

Need to make login_header function pluggable or add a do_action hook before the <html....> tag
Need to add a login_footer.

In fact what is required was highlighted in #4478 complete with diff file. This was marked as resolved BUT IT WAS NOT! I agree it might be a duplicate of issue #9682 BUT the underlying issue of being able to overwrite the login-header function WAS NOT solved.

(see recent support forum requests #252094 and #333994)

The solution MUST allow a replacement of login header (and even better also a replacement of the </body></html> tags from the switch statement with a login_footer function which could also be overrided - pluggable).

Thanks.

In an ideal world need to re-open #4478 to ensure accurate resolution.

Thanks

Change History (5)

comment:1 sleepuser4 years ago

  • Cc sleepuser added

comment:2 Denis-de-Bernardy4 years ago

  • Component changed from General to Users
  • Keywords needs-patch added
  • Milestone changed from Unassigned to Future Release
  • Priority changed from high to low
  • Type changed from defect (bug) to enhancement

comment:3 unsalkorkmaz4 years ago

  • Cc unsalkorkmaz added

comment:4 F J Kaiser4 years ago

  • Cc 24-7@… added

comment:5 johnbillion3 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17948.

Note: See TracTickets for help on using tickets.