WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12404 closed enhancement (duplicate)

Default Pretty Permalinks on Install

Reported by: mdawaffe Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Permalinks Keywords:
Focuses: Cc:

Description

Currently, we default to uglinks (http://example.com/?p=1) on new installs since we don't know if we can write to .htaccess ahead of time.

It'd be nice if we could set up pretty permalinks by default if possible.

A couple options to kick of some brainstorming.

  1. Set structure to /%year%/%monthnum%/%postname%/, see if it works behind the scenes. If it doesn't work, set to /index.php/%year%/%monthnum%/%postname%/, see if it works behind the scenes. If it doesn't work, set to uglinks.
  2. Enable query string based permalinks: /?%year%/%monthnum%/%postname%/. This would require changes to the wp and rewrite classes.

... other ideas?

In any case, we may want to prompt users to look at their permalink settings just after they install. If they change their structure a month later, their old links will be broken since we have no mechanism to redirect from either of the suggestions above to a new arbitrary structure. (The current default uglinks don't create this problem because we can always make a match from uglinks).

Though we could create such a heuristic mechanism:

If 404, look to see if request matches the default permalink structure, and if there's something there to redirect to, then 301.

Change History (3)

comment:1 mdawaffe4 years ago

Query String based permalinks: #12405

comment:3 nacin4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

In any case, we may want to prompt users to look at their permalink settings just after they install. If they change their structure a month later, their old links will be broken since we have no mechanism to redirect from either of the suggestions above to a new arbitrary structure. (The current default uglinks don't create this problem because we can always make a match from uglinks).

We already kind of prompt users, via a "Change Permalinks" button on the Add New Posts page. I don't like default pretty permalinks for the reasons described above (they will become broken on change). Beyond that, there's been talk about prompting them as part of an introduction process: see #11651 for the welcome screen concept, and #11008 for "Hello World" welcome post concept.

That all said, I'm going to close this as a duplicate of #6481.

Note: See TracTickets for help on using tickets.