WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12441 closed enhancement (duplicate)

_fill_user() should use get_user_meta()

Reported by: scribu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Optimization Keywords: has-patch commit
Focuses: Cc:

Description

Currently, _fill_user() does a direct query, when it could be using get_user_meta(), which is cached.

Attachments (1)

_fill_user.diff (1.3 KB) - added by scribu 6 years ago.

Download all attachments as: .zip

Change History (5)

@scribu6 years ago

comment:1 @scribu6 years ago

  • Keywords commit added

comment:2 @nacin6 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11914 it seems

comment:3 @miqrogroove6 years ago

Agreed. _fill_user() should never be called when the data are already cached, because the user object has already been filled. In any case, my patch already blows _fill_user() out of the water and hooks it up to goodies that are superior to get_user_meta(). :) Feedback would be appreciated on the other ticket.

comment:4 @voyagerfan57616 years ago

  • Cc WordPress@… added
Note: See TracTickets for help on using tickets.