WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#12444 closed defect (bug) (duplicate)

Install with Mu can't find wp_die if a database error occurs

Reported by: jmdh Owned by: dd32
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Reproduced in 2.9.1.1 (latest Mu release).

As discussed in http://mu.wordpress.org/forums/topic/16409
if a database error is encountered during the initial install, the following error message is displayed:

Fatal error: Call to undefined function wp_die() in /usr/share/wordpress-mu/wp-includes/wp-db.php on line 1147

Note that there is no Mu component and neither is the 2.9.1.1 version listed in this trac but http://trac.mu.wordpress.org/ tells me to report here.

In fact, I now see that the problem looks like it's been fixed in changeset 2071 in the mu subversion but in case anyone else ends up digging around, this bug report may be useful.

Change History (1)

#1 @nacin
9 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Will be fixed in MU 2.9.2, which I believe is at RC stage right now.

Note: See TracTickets for help on using tickets.