WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12447 closed defect (bug) (worksforme)

Post-Upgrade Database Update Failure

Reported by: zachware Owned by: ryan
Milestone: Priority: low
Severity: normal Version: 3.0
Component: Database Keywords:
Focuses: Cc:

Description

This will be the vaguest ticket I will ever file. I'm open to providing any logs or config needed.

Just pulled down the latest build of 3.0-alpha. Post download and install I'm greeted with a db repair needed message and a directive to add define('WP_ALLOW_REPAIR', true); to the wp-config. So I do.

I click repair database and end up at a "Are you sure you want to do this?" Screen with no Yes/No, only an option to Go Back.

It's stuck in a loop and the site is down. No config mods were made pre download and I've completely removed plugins and themes. Seems to be a bug but I can't identify the culprit in the logs I know to look for.

Change History (2)

comment:1 zachware4 years ago

  • Priority changed from high to low
  • Severity changed from blocker to normal

Update. I pulled down a nightly and uploaded manually. I got past the error.

The auto-upgrade script failed at the Test folder in wp-includes. Thus wp-settings couldn't find version.php (line 21.) I'm downgrading severity but suggest researching the update script / database error handling.

comment:2 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Without more to go on here, I'm going to close as worksforme. It seems the upgrade script had a hiccup. Re-open with feedback or steps to reproduce.

Note: See TracTickets for help on using tickets.