WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12472 closed enhancement (fixed)

Add AYS on unsaved menu changes

Reported by: Denis-de-Bernardy Owned by: koopersmith
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Menus Keywords: needs-patch
Focuses: Cc:

Description

if you edit a menu, and change its contents, by adding/removing items and/or editing existing items. if you forget to click save all changes before leaving, it discards the changes. the save all changes should not be needed, much like we're doing in the widgets screen.

Change History (9)

comment:1 voyagerfan57614 years ago

  • Cc WordPress@… added

comment:2 ocean904 years ago

  • Summary changed from confusing UI: edit / delete menu item to Add autosave on edit / delete menu item
  • Type changed from defect (bug) to feature request

Its not really a bug.

comment:3 jane4 years ago

I'd rather see an AYS. No autosave on menus. People will work on these and not want them updated without an explicit save/publish.

comment:4 ocean904 years ago

  • Keywords needs-patch added
  • Owner changed from janeforshort to koopersmith
  • Status changed from new to assigned
  • Summary changed from Add autosave on edit / delete menu item to Add AYS on unsaved menu changes
  • Type changed from feature request to enhancement

comment:5 markjaquith4 years ago

(In [14741]) Add AYS notice on unsaved menu changes. see #12472

comment:6 markjaquith4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Re-open if this needs more work.

Known issue that will not be fixed: if you make a change (like a sort, or an add, or a text modification) and then revert it, such that you are back at the original state, it will still think you've made a change. The change sensing is dumb... it triggers on the input/textarea/select changes, the "Add" events, the sort events, and the hierarchy change events.

Deletes happen asynchronously with their own AYS, so these don't count as a change.

comment:7 Denis-de-Bernardy4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Pardon for re-opening, but... why should widgets autosave whenever anything gets changed, while menu items should get an annoying AYS?

Mac pref screens autosave nearly all changed settings for good reasons.

comment:8 ryan4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

We don't autosave because we don't want push interim menu changes live. This is a big complaint with widgets. As you make modifications, they go live.

This is by design for 3.0. We'll see what the feedback looks like once 3.0 is out and adjust course as needed.

comment:9 voyagerfan57614 years ago

I was about to come and say the same thing as ryan. Something that's an integral part of the whole site layout like menus (and, yes, widgets) probably shouldn't auto-save. Ideally, users would have the ability to preview changes before they go live, but that could be a plugin.

Note: See TracTickets for help on using tickets.