WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#12497 closed defect (bug) (duplicate)

htaccess.ms has a slightly under-optimized rule

Reported by: Denis-de-Bernardy Owned by: nacin
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Multisite Keywords:
Focuses: Cc:

Description

it goes:

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]

inconveniently, this does not catch the root folder, because the latter won't match the dot.

this will, however:

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]

Change History (2)

comment:1 @wpmuguru5 years ago

  • Owner set to nacin
  • Status changed from new to assigned

Putting your name on it because you are doing the wpfs.

comment:2 @nacin5 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as duplicate of #12136 and incorporating this there.

Note: See TracTickets for help on using tickets.