Make WordPress Core

Opened 19 years ago

Closed 19 years ago

#1250 closed defect (bug) (invalid)

Number of posts in feeds is broken

Reported by: denis-de-bernardy's profile Denis de Bernardy Owned by:
Milestone: Priority: normal
Severity: major Version: 1.5.1
Component: General Keywords:
Focuses: Cc:


The rss and atom feeds only return the last post, rather than the user-defined n last posts.

Ex: (should spit 5 posts)

Attachments (1)

htaccess (21.9 KB) - added by Denis de Bernardy 19 years ago.

Download all attachments as: .zip

Change History (8)

#1 @Denis de Bernardy
19 years ago

  • Patch set to No

#2 @Denis de Bernardy
19 years ago

Another problem is: (should spit something)

#3 @Denis de Bernardy
19 years ago

I've included my .htaccess file in case it could be useful to solve the 2nd bug.

I doubt it, though, as: returns nothing

#4 @mikelittle
19 years ago

I cannot reproduce this with a brand new installation of the trunk at revision 2553.
I created a new db, created wp-config, installed, posted a second post and tried the feed. I got two entries.
Also .../category/uncategorized/feed gives me two entries.

Are there any other changes to your system? Plugins?
What is the value of Options -> Reading Options -> Syndication Feeds ->
Show the most recent: x posts?

#5 @Denis de Bernardy
19 years ago

i get the same thing as you do, in fact. i tried installing a fresh install, and i indeed get no problem with it.

despite this, my options are so that the main blog's feed and the dev blog's feed should display the 5 recent posts rather than the last one only.

i disabled all the plugins from my dev site, and the problem remains. it looks as if something somewhere stored that it should only display one post.

i'm investigating...

#6 @Denis de Bernardy
19 years ago

update -- i identified the faulty plugin. my browser's cache was misleading. sorry for the trouble. ;)

#7 @mikelittle
19 years ago

  • fixed_in_version set to 1.5.1
  • Resolution changed from 10 to 70
  • Status changed from new to closed

Marking resolved non issue after reporter's comment #2393

Note: See TracTickets for help on using tickets.