Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12514 closed defect (bug) (fixed)

Clean install with support for WP_HTTP_Streams fails with White-SOD

Reported by: westi Owned by: dd32
Milestone: 3.0 Priority: high
Severity: major Version: 3.0
Component: Upgrade/Install Keywords: needs, regression
Focuses: Cc:


I just tried a clean install of trunk on a MacPorts apache2/php5/mysql5 setup without curl installed.

This tries to use the fopen WP_HTTP_Streams HTTP implementation and I was getting a WSOD when it went off to fetch the secret keys from the API.

Change History (7)

comment:1 @westi6 years ago

PHP is v5.3.1

comment:2 @stgoos6 years ago

  • Cc steven@… added

Also experience config issues when trying to install the latest trunk version (13585) on my localhost LAMP with Apache v2.2.11 / MySQL v5.1.30 / PHP v5.2.8.

After you have entered the credentials in step one of the config I just get an empty screen for step 2 (url: /wp-admin/setup-config.php?step=2).

When I copy over a wp-config.php file from an other WP installation then WP works straight away without any issues so it looks like the config process is somehow broken.

Not really sure if this is related to the issue westi is describing here but I believe I don't have curl installed either.

comment:3 @dd326 years ago

westi: Can you pull up the error logs and find out if it was a fatal error being hit or something else?

comment:4 @dd326 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [13628]) Load WP_HTTP dependencies (translation support) for setup-config.php. Prevents a WSOD on attempted installs where external HTTP requests are blocked and/or timeout. Fixes #12514

comment:5 @dd326 years ago

The only way i could reproduce this was by forcing an error condition return. Which, by chance, included a translated string. Seems the translation classes were not being loaded for the config creator.

This doesnt load the translation files, instead the NOOP translation class is utilized.

comment:6 @westi6 years ago


The error log was empty but I've set up again with out curl on the same revision I was testing and reproduced the issue.

Nothing useful in the error log.

After a svn up to HEAD all is sparky :-)

comment:7 @dd326 years ago

After a svn up to HEAD all is sparky :-)

Cheers westi! :)

Note: See TracTickets for help on using tickets.